Не удается запустить Eclipse - Java была запущена, но вернул код выхода = 13

avatar
Ben E.
12 июля 2012 в 22:23
1649997
44
1010

Я пытаюсь впервые попробовать разработку под Android с помощью Eclipse. Я столкнулся с этой проблемой при попытке запустить Eclipse, установив версию 4.2 всего несколько минут назад.

После первой попытки запустить Eclipse без каких-либо параметров для указания виртуальной машины Java, я получил сообщение об ошибке, в котором говорилось, что это couldn't find a Java VM called javaw.exe inside the Eclipse folder, поэтому я нашел, где установлена ​​Java, и указал это место в качестве параметра в цели ярлыка. Теперь я получаю другую ошибку: Java was started but returned exit code=13.

Подобные вопросы, похоже, указывают на то, что это 32-битный / 64-битный конфликт, но я на 99% уверен, что скачал 64-битные версии Eclipse и Java (RE 7u5), которые я выбрал, потому что у меня 64-битные версии. бит Windows 7.

  • Если кто-нибудь знает, как подтвердить, что мои Eclipse и Java 64-битные, это будет оценено.
  • Если вы думаете, что моя проблема в другом, пожалуйста, помогите!
  • Пожалуйста, говорите как можно проще, так как я новичок в Eclipse и Java.

Цель ярлыка: "C: \ Program Files \ Eclipse-SDK-4.2-win32-x86_64 \ eclipse \ eclipse.exe" -vm "C: \ Program Files (x86) \ Java \ jre7 \ bin \ javaw.exe "

Полный код ошибки ...:

Java was started but returned exit code=13
C:\Program Files (x86)\Java\jre7\bin\javaw.exe
-Xms40m
-Xmx512m
-XX:MaxPermSize=256m
-jar C:\Program Files\Eclipse-SDK-4.2-win32-x86_64\eclipse\\plugins/org.eclipse.equinox.launcher_1.30v20120522-1813.jar
-os win32
-ws win32
-arch x86_64
-showsplash C:\Program Files\Eclipse-SDK-4.2-win32-x86_64\eclipse\\plugins\org.eclipse.platform_4.2.0.v201206081400\splash.bmp
-launcher C:\Program Files\Eclipse-SDK-4.2-win32-x86_64\eclipse\eclipse.exe
-name Eclipse
--launcher.library C:\Program Files\Eclipse-SDK-4.2-win32-x86_64\eclipse\\plugins/org.eclipse.equinox.launcher.win32.win32.x86_64_1.1.200.v201205221813\eclipse_1503.dll
-startup C:\Program Files\Eclipse-SDK-4.2-win32-x86_64\eclipse\\plugins/org.eclipse.equinox.launcher_1.30v20120522-1813.jar
--launcher.overrideVmargs
-exitdata 1e30_5c
-vm C:\Program Files (x86)\Java\jre7\bin\javaw.exe
-vmargs
-Xms40m
-Xmx512m
-XX:MaxPermSize=256m
-jar C:\Program Files\Eclipse-SDK-4.2-win32-x86_64\eclipse\\plugins/org.eclipse.equinox.launcher_1.30v20120522-1813.jar
Источник
DGH
12 июля 2012 в 22:26
0

«Program Files (x86)» - это то место, куда Windows сегодня обычно помещает 32-битные файлы. Я не уверен, как именно проверить вашу версию Java, но вы всегда можете удалить и загрузить ее заново.

Tomáš Zato - Reinstate Monica
17 сентября 2015 в 14:34
2

@ user1522092 Как, черт возьми, вы получили доступ к тексту сообщения об ошибке? На моем ПК его нельзя скопировать, пришлось набирать на клавиатуре ...

SwapnilPopat
17 мая 2017 в 07:33
0

@ TomášZato выберите это сообщение об ошибке и используйте сочетание клавиш - Ctrl + C. Оно будет скопировано.

Matthias Luh
18 ноября 2020 в 12:40
0

Подобная ошибка может также возникнуть «из ниоткуда» из-за автоматического обновления Java. Ответ ДНК помог мне в этом случае после того, как я (повторно -?) Установил 32-битный JDK в каталог без пробелов и указал "-vm C: \ path_to_jdk \ javaw.exe" в eclipse.ini

Ответы (44)

avatar
tk_
3 января 2017 в 10:54
224

Существуют рабочие комбинации разрядности ОС, JDK и Eclipse. В моем случае я использовал 64-битный JDK с 32-битным Eclipse в 64-битной ОС. После перехода на 32-разрядную версию JDK Eclipse начал работать.

Используйте одну из следующих комбинаций.

  • 32-разрядная ОС, 32-разрядная версия JDK, 32-разрядная версия Eclipse (только 32-разрядная версия)
  • 64-битная ОС, 32-битная JDK, 32-битная Eclipse
  • 64-разрядная ОС, 64-разрядная версия JDK, 64-разрядная версия Eclipse (только 64-разрядная версия)
stark
9 апреля 2021 в 15:37
2

Обратите внимание, что можно установить как 32-разрядную, так и 64-разрядную версию jre.

avatar
Gaurav
14 мая 2020 в 20:55
0

это может быть проблема с комбинациями JDK или проблема с версией JDK, выберите правильную. Я использую комбинацию 64-битной операционной системы, 64-битной JDK, 64-битной Eclipse IDE.

avatar
Varun Saxena
4 февраля 2020 в 11:50
4

В "Путь" переменная удалена "C: \ ProgramData \ Oracle \ Java \ javapath" и заменил его на "C: \ Program Files \ Java \ jdk1.8.0_212 \ bin"

У меня это сработало.

avatar
Sankar
30 сентября 2019 в 10:29
0

В моем случае у меня есть два разных JDK: IBM и Oracle JDK. Я переместил IBM JDK в начало Oracle JDK в переменной среды, и это сработало. Примечание: я собираюсь использовать IBM JDK, поэтому я перешел на более высокий уровень.

avatar
minigeek
24 августа 2019 в 18:12
2

Если на вашем компьютере установлено несколько версий Java, вы можете просто указать eclipse, где и где использовать javaw.exe.

В моем случае у меня есть IBM JDK, с Oracle JDK тоже, но для захвата eclipse, добавлены следующие строки в файл eclipse.ini в каталоге eclipse, и это сработало.

-vm
C:/WAS9DEV/java/8.0/bin/javaw.exe

Путь к вашей папке java необходимо заменить в примере выше

Надеюсь, это поможет.

avatar
Saurabh Prakash
5 апреля 2019 в 10:27
11

Вам нужно перейти в папку, в которой установлен eclipse, а затем изменить файл eclipse.ini.

Вы должны добавить

-vm

C: \ Program Files \ Java \ jdk1.8.0_202 \ bin \ javaw.exe

Ваш файл eclipse.ini будет выглядеть как на скриншоте ниже

enter image description here

garnet
18 июня 2019 в 08:19
0

Дополнительные сведения об этом решении см. На coderhelper.com/a/11461676/1756069.

avatar
HoosierDude
27 февраля 2018 в 03:21
-1

У меня была такая же проблема ... я установил STS, но постоянно получал сообщение «java была запущена, но вернул код выхода = 13». Моя проблема заключалась в том, что я использовал установочный файл по умолчанию, который не зависел от процессора, из https://spring.io/tools/sts. Мне пришлось погрузиться глубже, чтобы быть точным при загрузке 64-битной версии. Не было интуитивно понятно, какую версию вы загружаете. Как только я получил 64-битную версию (обратите внимание, что zip-файл по-прежнему включает в себя «win32», просто добавляет «-64» в конце), все заработало.

avatar
Alexander
27 декабря 2017 в 02:39
2

Рискуя не добавить большой ценности к существующим ответам, но, пройдя через весь этот беспорядок, я хотел бы посмотреть, смогу ли я закрепить, как я решил проблему:

  1. Вести разработку отдельно от обычных машинных сред. Причина этого в том, что на вашем компьютере, вероятно, работает много приложений, о которых вы не знаете и которые нуждаются в периодическом обновлении Java, например, банковские приложения и приложения безопасности. Когда происходят эти обновления, они изменяют переменные среды, поэтому, если вы используете их в своей среде разработки, обновление почти наверняка нарушит вашу настройку Eclipse.

  2. Установите версии Eclipse, 32- или 64-разрядные, в зависимости от ваших подключаемых модулей и т. Д. Причина в том, что многим подключаемым модулям по-прежнему требуется 32-разрядная версия, и попытка их установки в 64-разрядной среде вызывает множество неясных (очень непонятных) ошибок. Это означает, например, что вам, возможно, придется иметь отдельные экземпляры Eclipse для среды разработки Java EE, PHP, Python, Assembler и т. Д. Это может показаться обременительным, но для меня это было благословением.

  3. Установите две среды выполнения Java еще раз, одну 32-битную и одну 64-битную, а затем отредактируйте eclipse.ini для каждой из ваших установок, чтобы указать правильную JRE, не JRE HOME в переменных среды . Я создаю каталог в C:\Java\64bit\jdk1.7.0_15\ и C:\Java\32bit\etc, а в вашем файле eclipse.ini вы добавляете строку -vm C:\Java\64bit\jdk1.7.0_15\bin, чтобы указать на вашу необходимую среду выполнения java.

После того, как все вышесказанное будет выполнено, вы сможете устанавливать сколько угодно обновлений Java SDK, но ваша среда разработки никогда не сломается. Если вам нужно обновить среду выполнения разработки, просто измените путь -vm в вашем eclipse.ini

avatar
Siddarth Kanted
4 ноября 2017 в 08:21
6
  1. Убедитесь, что в системных переменных среды удален "C: \ ProgramData \ Oracle \ Java \ javapath".

  2. Убедитесь, что в системных переменных среды добавлен "C: \ Program Files \ Java \ jdk1.8.0_131 \ bin".

enter image description here

avatar
Pythoner
25 октября 2016 в 01:31
13

Найдите eclipse.ini:

Часто в C:\Users\xxx\eclipse\jee-neon\eclipse добавляют

-vm
 C:\Program Files (x86)\Java\jre7\bin\javaw.exe

после

--launcher.appendVmargs
Brian Gleeson - IBM
9 января 2017 в 11:53
0

Одно важное замечание, которое меня зацепило, - это указать путь в отдельной строке к -vm, как отмечалось в документации

avatar
dush88c
26 сентября 2016 в 08:55
4

Убедитесь, что вы установили два пути JAVA в разделе Environment Variable. Если вы уже установили две версии JDK, возможно, тогда еще раз проверьте, что вы указали PATH для Java, как показано ниже.

PATH -->  C:\ProgramData\Oracle\Java\javapath

, а также

JAVA_HOME ---> C:\Program Files\Java\jdk1.7.0_02\bin

Если присутствуют оба, то может возникнуть ошибка такого рода.

Если все в порядке, проверьте в файле ".ini" указанную ниже область. Откройте файл ".ini" и проверьте

 -VM  path is  C:\Program Files\Java\jdk1.7.0_79\bin\

Если нет, установите его так и запустите снова.

Maude
24 августа 2018 в 13:34
1

Обратите внимание, что путь jdk у меня не работал, это должен был быть jre

avatar
The HCD
27 мая 2016 в 07:51
1

Главный ответ не сработал для меня: у меня не было переменных среды, определяющих путь к Java, или нет Java на моем пути.

Однако путь C: \ ProgramData \ Oracle \ Java \ javapath \ javaw.exe всегда присутствовал во всплывающем окне ошибки Eclipse 4.5 (Mars) в параметре -vm, даже если я пытался переопределить в файле eclipse.ini .

Я решил эту проблему, открыв командную строку, сделав cd'ing каталог, в котором находился eclipse.exe, и использовал MKLink:

C:\EclipseMars> mklink javaw.exe "C:\Program Files\Java\jdk1.7.0_79\bin"
symbolic link created for javaw.exe <<===>> C:\Program Files\Java\jdk1.7.0_79\bin

Никаких изменений в eclipse.ini не требовалось.

Я попытался указать параметр -vm в eclipse.ini, и он был учтен, но во всплывающем окне с ошибкой дважды присутствовал параметр -vm, даже если в затмении присутствовал только один -vm .ini.

В моем eclipse.ini у меня нет опции -vm, и кажется, что только символическая ссылка исправила ее.

sharcfinz
29 августа 2016 в 14:36
0

У меня не сработало, и в итоге я получил сообщение «JVM завершено. Код выхода = 2». Оказывается, мне нужно было установить jre для 64-разрядной версии, которая соответствует 32-разрядной версии, ранее установленной во время недавнего обновления.

avatar
James Wierzba
21 января 2016 в 22:11
1

Я решил эту проблему, установив JDK (v7 update 80), тогда как раньше у меня была установлена ​​только JRE.

Примечание: это было для программного обеспечения IBM RTC (построенного на Eclipse).

avatar
Bhanupratap Singh
26 июля 2015 в 19:48
3

Этот тип ошибок возникает в основном из-за использования разных версий Java с разными версиями Eclipse.

Предположим, вы устанавливаете в своей системе 64-битный JDK. Затем убедитесь, что вы установили с ним Eclipse с 64-разрядной версией.

И если вы устанавливаете 32-разрядную версию JDK в своей системе, убедитесь, что вы устанавливаете 32-разрядную версию Eclipse вместе с ней.

У меня была аналогичная проблема. Я установил 32-битный JDK и пытался использовать 64-битный Eclipse.

Но когда я установил 64-битный JDK в свою систему, Eclipse начал работать без проблем.

Рекомендуется лучше установить 32-разрядную версию Java вместе с 32-разрядной версией Eclipse в системе с 32-разрядной конфигурацией и аналогично для 64-разрядных систем.

Это помогает повысить производительность системы.

avatar
hamish
22 июня 2015 в 02:51
10

Оказалось, что у меня была установлена ​​только 32-битная среда выполнения Java.

C:\Program Files (x86)\Java\jre1.8.0_45\

Все, чего действительно хотел Eclipse, - это установить 64-битную среду выполнения Java. <= РЕШЕНО

Java SE Runtime Environment 8u45  jdk-8u45-windows-x64.exe

http://www.oracle.com/technetwork/java/javase/downloads/jre8-downloads-2133155.html

Confirm your installation by checking you now have this folder

    C:\Program Files\Java\jre1.8.0_45\
Dane411
27 июня 2015 в 01:32
0

возможно, вы имели в виду "jre-8u45-windows-x64.exe" вместо "jdk-8u45-windows-x64.exe"

avatar
TastyCode
16 марта 2015 в 13:52
25

Добавление аргумента vm в файл .ini сработало для меня

-vm
C:\Program Files\Java\jdk1.7.0_65\bin\javaw.exe
user1880957
6 апреля 2015 в 05:52
0

В моем случае сервер Tomcat (в пределах eclipse) не был остановлен должным образом из-за более раннего запуска. Итак, мне пришлось убить eclipse из диспетчера задач Windows. После этого затмение больше не начиналось. Когда я добавил это решение, оно снова заработало. Кажется странным, но это действительно было исправление.

avatar
Touchstone
13 марта 2015 в 07:35
5

Я тоже столкнулся с той же проблемой. Оказалось, что переменная среды Path указывала на неправильную версию Java.

Проверьте переменную среды и укажите в ней правильную Java. Например:

C:\Program Files (x86)\Java\jdk1.6.0_17\bin

Чтобы проверить переменную среды, перейдите по адресу:

Computer → properties → Advanced system settings → Advanced -> Environment variables
avatar
Patricia
21 февраля 2015 в 13:49
9

Я получил это сообщение, когда забыл установить JDK.

Amit Kumar
20 октября 2015 в 13:12
1

Как eclipse может сказать, что java была запущена, если ее нет на вашем компьютере?

Michał Szałapski
11 декабря 2015 в 18:17
0

У меня работает :) После обычного обновления до 1.8 я не устанавливал JDK вручную. Теперь все работает нормально.

Thorbjørn Ravn Andersen
19 сентября 2019 в 10:13
0

@AmitKumar Вероятно, загрузите установленную по умолчанию версию Java для браузера.

avatar
Benjamin
13 февраля 2015 в 12:46
11

Чистая переустановка Java JDK сработала в моем случае. Сейчас я использую Eclipse 4.4 (Luna) как шарм.

avatar
fresko
10 февраля 2015 в 09:13
9

Лучший ответ здесь - слишком длинный. Я не могу комментировать, поэтому добавил свой ответ.

  1. Иди сюда: http://www.oracle.com/technetwork/java/javase/downloads/index.html
  2. Загрузите последнюю версию SDK (конечно, для x64, если ваш компьютер - x64)
  3. Установить
  4. Теперь вечеринка окончена, и пора работать с Eclipse;)
avatar
Peter Huang
8 февраля 2015 в 17:10
4

У меня была такая же проблема после обновления JDK с 1.7 до 1.8. Я использую Eclipse 4.4 (Luna). Ошибка исчезла после того, как я понизил JDK до 1.7.

avatar
IrfanClemson
23 января 2015 в 13:59
4

У меня была аналогичная ошибка после установки Java 8 в моей 64-битной системе Windows 7.

Изменение переменных среды и т. Д. Не помогло. Поэтому я попытался удалить Java Update 8, но это тоже не помогло. Моя проблема была решена после загрузки и установки 64-разрядной версии Java 8 SDK. Надеюсь, это поможет.

avatar
mtyson
6 января 2015 в 22:58
5

У меня была эта проблема. Я установил Java 8 update 25 через Chrome, и после попытки запустить Eclipse возникла упомянутая ошибка.

Это обновление было удалено, и Eclipse снова заработал.

avatar
kapil thadani
26 декабря 2014 в 09:03
2

Если ничего не работает, последнее решение, которое вы можете попробовать, - это полностью удалить Java с вашего компьютера, а затем установить ее снова и убедиться, что переменные пути установлены правильно.

avatar
Jitendra
18 декабря 2014 в 10:17
5

Я попробовал следующее решение:

Я создал ярлык javaw.exe из пути C: \ Program Files \ Java \ jdk1.7.0_71 \ bin и вставил его в путь C: \ ProgramData \ Oracle \ Java \ javapath .

После этого я запустил Eclipse, и он у меня сработал.

avatar
Sabri Meviş
15 декабря 2014 в 18:30
2

У меня был x64-битный JDK. В настройках моего пути ничего не было. Итак, я установил x86 JDK. Это отлично решило мою проблему.

avatar
dreamdeveloper
13 декабря 2014 в 18:20
26

enter image description here

Проблема была устранена путем выполнения следующих действий.

  1. Eclipse находит исполняемые файлы JAVA из 'C: \ ProgramData \ Oracle \ Java \ javapath'

  2. Структура папок будет содержать ярлыки для следующих исполняемых файлов,
    я. java.exe
    II. javaw.exe
    iii. javaws.exe

  3. Для меня пути к исполняемым файлам указывали на мои Program Files (x86) (главная для 32-битных приложений) расположение папки

  4. Я исправил его на Program Files (в котором размещаются 64-битные приложения), и проблема была решена

Найдите то же самое на скриншоте.

JuliandotNut
2 июля 2015 в 18:36
0

Это означает, что это была проблема 32-битной и 64-битной, как упоминалось в верхнем ответе. :) Ура хоть

V15I0N
2 сентября 2015 в 13:25
1

Эти упомянутые файлы были созданы или изменены на моем ПК с последним обновлением от Oracle - чтобы они не работали! Это действительно не так, как должно быть ... 32-битное обновление просто незаметно удалило 64-битную установку

stack1
22 сентября 2015 в 17:54
1

Как мне поменять его на программные файлы 64 бит? Я щелкаю правой кнопкой мыши java.exe> ​​свойства> вкладка ярлыка. Целевое поле нельзя изменить.

dreamdeveloper
5 января 2016 в 09:00
0

Вы просто удаляете 32-битные файлы и копируете их из 64-битного пути (внутри программных файлов)

dreamdeveloper
24 января 2019 в 07:33
0

Вы просто удаляете 32-битные файлы и копируете их из 64-битного пути (внутри Program files \ Common Files \ Oracle \ Java \ javapath)

avatar
RustyIngles
3 декабря 2014 в 07:03
122

Для меня решение заключалось в том, чтобы войти (в Windows 8.1):

System > Advanced system setting > Environment Variables 

В разделе «Системные переменные» в переменной «Путь» сначала было следующее:

C:\ProgramData\Oracle\Java\javapath;

Я удалил это, и Eclipse снова заработал!

boumbh
23 февраля 2015 в 08:07
1

Работал и на Windows 7, похоже, что установка Java 8 испортила переменные среды.

avatastic
5 марта 2015 в 11:50
0

Это сработало для меня (Win7 x64). Я подозреваю, что эта запись была добавлена ​​после установки 32-битной jre 8 для Firefox.

KostasA
8 марта 2015 в 17:40
0

Спасибо чувак! У меня есть ОС (win7 x64), и это решение вызвало запуск затмения!

Sathesh Balakrishnan Manohar
25 января 2016 в 18:50
0

Идеально работал как шарм :) работал у меня в Windows 8 64 бит

Zorglube
11 декабря 2017 в 16:17
0

Я сделал то же самое, просто поставил C: \ ProgramData \ Oracle \ Java \ javapath; в конце (последней записи) моего «Пути», так что eclipse находит «правильную» JVM перед «неправильной».

MasterJoe
27 марта 2019 в 23:01
0

Кто-нибудь знает, почему это работает? Это сработало и для меня.

avatar
Kandy
24 ноября 2014 в 06:35
5

Я пробовал некоторые решения, но у меня ничего не вышло.

Наконец, я нашел другой способ ...

Перейдите к Переменным среды Системным переменным

Задайте для C: \ Program Files \ Java \ jdk1.7.0_02 \ bin \ javaw.exe путь в системных переменных.

Попробуйте. У меня это сработало ...

Débora
24 сентября 2015 в 18:43
1

Я применил все другие решения, но они не работали для моих окон 10. В любом случае, ваше решение сработало для меня и сэкономило мне много часов .... САЛЮТ !!!. Огромное спасибо.

avatar
Girish Sakhare
18 ноября 2014 в 14:38
1

Я столкнулся с той же проблемой. Я установил версию 8 и обновил 25 32 бит.

Для исправления установите Java SE Development Kit 7 Update 71 (64-разрядная версия). Затем через appwiz.cpl удалите другую версию, например, Java Update 25. Готово.

avatar
Fenwick
6 ноября 2014 в 16:28
4

Я только что решил ту же проблему при настройке моего ПК с Windows 8.1. Точно так же, как @George Papatheodorou, упомянутый выше (извините, я не могу добавить комментарий), Eclipse и JRE должны быть как 64-битными, так и 32-битными.

Однако, похоже, для среды Windows 8 / 8.1 вы получите 32-разрядную JRE по умолчанию (и я не знаю, где изменить это значение по умолчанию для загрузки), как объясняется здесь: http: //java.com/en/download/faq/win8_faq.xml

Я использовал 64-битную версию Eclipse, поэтому возникло несоответствие. Затем я установил 32-битный Eclipse, и на этот раз все работает нормально.

Поэтому, прежде чем беспокоиться об изменении каких-либо переменных среды, проверьте свою версию JRE и Eclipse.

Конечно, вы можете использовать 64-битную JRE с 64-битным Eclipse. Просто убедитесь, что они совпадают, потому что Windows 8.1 по умолчанию предоставляет 32-разрядную версию.

avatar
mortensi
3 ноября 2014 в 07:20
255

Я получил эту ошибку и обнаружил, что моя переменная PATH (в Windows), вероятно, была изменена. Сначала в моем PATH была эта запись:

C:\ProgramData\Oracle\Java\javapath

... и Eclipse запустил "C:\ProgramData\Oracle\Java\javapath\javaw" - что дало ошибку. Я подозреваю, что это что-то, что пришло вместе с установкой Java 8.

У меня установлено несколько версий Java (6,7 и 8), поэтому я удалил эту запись из PATH и снова попытался перезапустить Eclipse, что сработало нормально.

Если это не работает для вас, вам необходимо обновить JDK (до версии Java - 8 в данном случае).

Инструкции по редактированию переменной PATH

PolyMesh
25 ноября 2014 в 05:01
0

Я только что обнаружил эту проблему и заметил, что этот же путь добавлен к моей переменной env PATH. Я только что установил VirtualBox вчера, поэтому предполагаю, что это виноват.

Pablo
26 ноября 2014 в 07:29
13

У меня была такая же проблема, и я пробовал разные варианты, но решил ее только после удаления записи «C: \ ProgramData \ Oracle \ Java \ javapath» из переменной PATH. Хороший улов!

Chinmoy
2 января 2015 в 14:51
6

Отличный улов !!! Ребята, проверьте вашу переменную Env.PATH и удалите этот C: \ ProgramData \ Oracle \ Java \ javapath; ... Я думаю, он добавлен после обновления JRE8.

Lou Morda
22 января 2015 в 16:04
0

так .. Oracle не только удалил мой путь java7 var, но он теперь использует "ProgramData"? что за хрень?

Halogen
6 сентября 2015 в 04:23
0

Также наткнулся на эту вещь javapath. В дополнение к его удалению мне также пришлось добавить переменную PATH к моему текущему JDK (1.7.0_09). Похоже, что при установке разных версий JDK / JRE переменные env устанавливаются по-разному.

b1nary.atr0phy
5 августа 2016 в 05:14
3

Зачем удалять запись, если вместо этого можно просто указать ей правильный каталог?

AnkitK
26 августа 2017 в 08:22
0

Я тоже столкнулся с этой ошибкой в ​​Windows. Удалена запись Java PATH в системных переменных, созданная виртуальным ящиком Oracle. Затмение тогда запустилось нормально.

JoeMjr2
7 декабря 2017 в 16:11
0

Я просто хотел упомянуть, что это случилось со мной после установки IntelliJ IDEA IDE. Удаление этой строки из переменной среды Path зафиксировало Eclipse, и, насколько я могу судить, IDEA все еще работает.

mm6
4 апреля 2019 в 13:44
0

Это действительно работает!!! но почему установки java 8 возятся с переменными env.

avatar
Jaswanth Kumar
30 октября 2014 в 14:06
182

Если вы недавно установили Java 8 и удалили Java 7, установите JDK 8 и повторите попытку.

Shudy
27 февраля 2015 в 09:59
11

Это сработало для меня. Я установил Java 8 (у меня был J7), но забыл установить JDK8. Я сделал это и "вуаля". Спасибо!

Charles J. Daniels
14 марта 2015 в 12:31
0

Это сработало для меня после установки Java 8, хотя я никогда не удалял другие версии java.

WhyGeeEx
9 июня 2015 в 16:58
2

Мансур. В Java 8 Oracle объединила удаление предыдущих версий с установкой. Если вы выбрали этот вариант при установке, удаление может оставить вас ни с чем.

ChristophK
29 января 2016 в 17:48
3

Я отказываюсь устанавливать SDK, когда мне действительно нужна только среда выполнения.

E-Riz
5 апреля 2016 в 16:21
0

Для ясности: exit code=13 - это , всегда , вызванное несоответствием битов между Eclipse и JVM. Люди могут прийти к этому по-разному, но, в конце концов, это не вызвано конкретной версией Java (6 против 7 против 8) или тем, используете ли вы JRE против JDK - это всегда немного укоренено. несоответствие. См. Принятый ответ выше.

avatar
Adam Burley
27 октября 2014 в 15:53
1

Я обнаружил, что по ошибке установил 32-битный Eclipse и пытался использовать его с 64-битной JRE, поэтому я получил эту ошибку. Чтобы узнать, установлен ли у вас 32-разрядный или 64-разрядный Eclipse, см. Этот ответ: https://coderhelper.com/a/9578565/191761

avatar
George Papatheodorou
23 октября 2014 в 08:49
6

Если вы устанавливаете 64-битную версию Eclipse на ПК с 32-битной JRE, это гарантированно произойдет.

Итак, решение довольно простое: вам нужно синхронизировать их, обновив любой из них. Это произойдет при загрузке промежуточного программного обеспечения Oracle Fusion, и Eclipse ожидает 32-разрядную среду, в то время как ваш JRE - 64-разрядный, а ваш домашний JAVA указывает на 64-разрядный JDK.

Maximiliano Rios
22 июля 2015 в 06:51
0

Мой случай действительно. Несоответствие между 32 и 64 битами является классическим. Я даже не помнил, скачал ли я 64-битную версию, пока не использовал java -version

avatar
user1336321
21 октября 2014 в 16:01
2

Это может произойти, если у вас есть несколько версий Java на одном компьютере. Чтобы исправить это, я сделал следующее:

  1. Проверено текущее значение JAVA_HOME. В Windows echo %JAVA_HOME%
  2. Доступ к маршруту javaw.exe
  3. Заменены ярлыки, указывающие на домашний каталог Java.
avatar
Shetty's
21 октября 2014 в 06:22
11

Я удалил обновление Java 25, и проблема была решена.

Pritish Shah
8 ноября 2014 в 15:33
3

Это потому, что, вероятно, вы используете jdk 1.7, а плагин браузера установил java 8 update 25 для видео. Если вы обновите свой jdk до 1.8, в этом случае эта ошибка исчезнет. Либо обновите jdk, либо удалите плагин. Странное решение.

Vinícius Barros
23 ноября 2014 в 21:05
0

Я обновил свою версию java, потому что плагин браузера нуждался в обновлении. Это все равно не сработало, и в итоге у меня не было полнофункционального Eclipse. Это отстой!

avatar
Pir Fahim Shah
7 августа 2014 в 05:37
7

У меня была такая же проблема. Я использовал Windows 8 с 64-битной ОС. Я просто изменил путь на Program Files (x86), и он начал работать. Я поместил эту строку в файл eclipse.ini:

-vm
 C:\Program Files (x86)\Java\jre7\bin\javaw.exe
Xavi Montero
7 октября 2014 в 10:43
0

Я 64-битный. Когда я установил jdk1.8.0_20 для 64 бит, он попросил меня перезагрузиться. Я сделал. Он оставил JRE в Program Files (x86) и только DLL в 64-битном Program Files (без javaw.exe), поэтому я указал -vm на Program Files (x86). У меня все еще есть code=13. С этим ashout.com/fix-java-started-returned-exit-code13-eclipse я понял, что битовые версии «должны» соответствовать да или да. Итак, я запускаю тот же установщик JDK во второй раз. На удивление он развернул новые файлы, которые отсутствовали в первый раз. Теперь он работает с -vm в C:\Program Files\Java\jdk1.8.0_20\bin\javaw.exe.

Peter Mortensen
30 декабря 2016 в 23:26
0

Это действительно две строчки в файле eclipse.ini?

Pir Fahim Shah
31 декабря 2016 в 13:02
0

@PeterMortensen да, ты пробовал

avatar
Asokan
27 мая 2013 в 10:15
6

Убедитесь, что у вас нет специальных символов (%, $, # и т. Д.) В пути Eclipse.

Dave C
24 июня 2014 в 23:13
0

Это было для меня! У меня была папка eclipse на рабочем столе, и у активного пользователя был специальный символ в имени пользователя.

Peter Mortensen
30 декабря 2016 в 23:22
1

Это уже покрыто ответом bello, опубликованным примерно за полгода до этого.

avatar
Katusepi
23 января 2013 в 09:22
66

У меня была такая же проблема, Java была запущена, но вернул код выхода = 13 .

Мое решение заключалось в создании переменной среды для свойств Windows имя переменной = PATH значение переменной = C: \ Program Files \ Java \ jdk1.7.0_02 \ bin , а не в C: \ Program Files (x86) \ Java \ jre7 \ bin .

Затем я добавил строку в файл eclipse.ini → C: \ Program Files \ Java \ jdk1.7.0_02 \ bin \ javaw.exe.

У меня это сработало.

Mohit
6 ноября 2014 в 06:33
5

Я обновил java, поэтому обновление java изменило env. переменное значение, фиксированный окр. var. значение, поэтому он начал работать.

farheen
10 ноября 2014 в 11:20
5

Спасибо, Мохит, я тоже обновил java для firefox, и переменная пути была обновлена ​​как C: \ ProgramData \ Oracle \ Java \ javapath; Следовательно, затмение не было инициализировано. Спасибо еще раз.

Kannan_SJD
13 января 2015 в 05:58
1

Спасибо, Катусепи ... В моем случае это сработало как шарм ... Но мне интересно, как переменная среды изменяется без моего (администратора) разрешения в Windows .. !!!

TheZuck
18 апреля 2015 в 19:25
0

та же проблема с путём, идущим не в нужное место

desw
27 апреля 2015 в 08:19
0

Спасибо, это сэкономило мне много времени. Со своей стороны мне пришлось установить 64-битный jdk и изменить переменную среды, которую изменили обновления.

Swaroop
29 июля 2015 в 15:05
0

Спасибо, была та же проблема, когда мой путь был установлен на C: \ ProgramData \ Oracle \ Java \ javapath, и я переместил его в конец.

HIREN011
18 февраля 2016 в 17:52
0

@Kannan_SJD => Как именно вы модифицировали файл eclipse.ini? У меня также нет прав администратора, и мне нужно решить эту же проблему. Когда я добавил «-vm c: \ My_JDK_1.6_Dir \ bin \ javaw.exe», он по-прежнему выдавал ту же ошибку - код выхода 13, и я вижу, что в полном журнале ошибок отображаются две строки «-vm c: \ My_JDK_1.6_Dir \ bin \ javaw.exe "и" -vm c: \ ProgramData \ Oracle \ Java \ javapath \ javaw.exe ". Я хочу убедиться, что он запускает мой JRE / JDK 1.6, а не тот из PATH, который указывает на 1.8

Indrajeet Gour
1 июня 2016 в 05:59
0

Я не был обновлен, eclipse.ini просто добавил папку bin jdk в PATH и она работает для меня.

avatar
bello
4 декабря 2012 в 10:50
23

Самое странное исправление на свете. Посмотрите на свой путь Eclipse и убедитесь, что у вас нет странных символов (например, !, # и @). У меня это сработало.

roded
3 февраля 2016 в 08:46
1

Есть ли по этому поводу открытый вопрос?

avatar
blueray
25 октября 2012 в 01:44
10

Решение простое: поместите папку «eclipse» в «C: / Program Files». Если не работает, поместите его в «C: / Program Files (x86)».

Steve Kline
12 марта 2014 в 00:17
1

Это решение, а также удаление полного пути и использование только «Javaw.exe» сработало для меня.

Stevko
1 августа 2014 в 16:34
0

Остерегайтесь этого решения, если вы работаете с управляемым экземпляром Windows. В большинстве доменов IT / Sec дерево каталогов Program Files заблокировано для доступа на запись, что затмевает fubars.

randomuser
2 декабря 2020 в 00:33
0

У меня была такая же проблема с Lua Development Tools, и это решение сработало для меня!

avatar
vishal129
12 июля 2012 в 22:38
4

Это могло произойти из-за недостатка памяти. Вы можете изменить файл eclipse.ini, чтобы увеличить объем памяти. Что-то вроде этого может вам помочь: FAQ Как увеличить размер кучи, доступный для Eclipse?

avatar
DNA
12 июля 2012 в 22:29
763

Ваша версия Eclipse 64-битная, в зависимости от путей и имен файлов. Однако версия Java, которую он загружает, является 32-битной, на что указывает ее источник в этой строке:

-vm C:\Program Files (x86)\Java\jre7\bin\javaw.exe

Program Files (x86) - это папка, в которой 64-разрядная Windows помещает 32-разрядные программы.

Program Files - это папка, в которой 64-разрядная Windows помещает 64-разрядные программы.

Это может произойти, если в системе установлено несколько JVM, как это часто бывает в 64-разрядной версии Windows (например, на странице загрузки JRE используется разрядность браузера, чтобы определить, какая разрядность загружается в предлагаем вам, и многие люди используют (d) 32-битные браузеры, даже если они работают под 64-битной Windows).

Лучший способ исправить это, если у вас действительно есть 64-битная JRE или JDK в вашей системе, - это указать в eclipse.ini, какую именно JVM вы хотите использовать. Инструкции подробно описаны на вики-странице Eclipse, но в основном вы должны указать параметр -vm в ini-файле - обязательно внимательно прочитайте вики-страницу, поскольку формат очень специфичен.

Настоятельно рекомендуется указывать путь JVM в eclipse.ini, потому что это изолирует Eclipse от любых потенциальных изменений в вашей системе PATH, которые могут быть сделаны некоторыми установщиками программ (я говорю с вами, Oracle!).

Другой вариант - загрузить и использовать 32-битный Eclipse вместо 64-битного, но все же настоятельно рекомендуется указать путь к JVM в eclipse.ini.


Осталось для исторической справки :

Чтобы проверить свою версию Java, запустите

  java -version 

в консоли (командной строке). В Windows 7 с 64-битной Java 6 я получаю:

  java version "1.6.0_27"
  Java(TM) SE Runtime Environment (build 1.6.0_27-b07)
  Java HotSpot(TM) 64-Bit Server VM (build 20.2-b06, mixed mode)

Обратите внимание на 3-ю строку, которая показывает, что это 64-битная версия.

В 32-битной версии вы получите что-то вроде:

  Java HotSpot(TM) Client VM (build 20.1-b02, mixed mode, sharing) 

Если вы работаете на 64-битной машине, вы можете установить 64-битный JDK и удалить 32-битный. Например, в Windows 10 просто зайдите в «Настройки» и в разделе «Приложения» вы найдете Java. Нажмите на нее, и вы найдете все разные версии. Теперь вы можете выбрать, какой из них удалить.

Ozan Atmar
24 июня 2014 в 11:24
9

Что ж, 3-й комментарий мне помог. Я не понимал, что такое «Клиентская виртуальная машина Java HotSpot (TM) (сборка 20.1-b02, смешанный режим, совместное использование)». Теперь я знаю, что мне нужно скачать java-64bit

James Okpe George
21 июля 2014 в 19:57
0

Как мне это сделать, у меня такая же проблема, и я не могу понять, что вы имеете в виду, называя это явно, вы имеете в виду, как из командной строки

DNA
21 июля 2014 в 21:04
0

Да, из командной строки (используя путь к файлу, указанный в сообщении об ошибке, не обязательно приведенный мной пример!)

QPTR
22 ноября 2014 в 03:33
0

Здравствуйте, у меня такая же проблема, поэтому я использовал эту команду, как вы упомянули, но она открыла диалоговое окно с ошибкой: Не удалось создать виртуальную машину Java, возникло фатальное исключение. Не могли бы вы помочь с этим?

DNA
22 ноября 2014 в 18:16
0

См. Этот вопрос (coderhelper.com/questions/25609405/…) и убедитесь, что вы правильно набираете команду. В противном случае я предлагаю вам начать новый вопрос с вашей конкретной проблемы.

alexl
22 февраля 2015 в 07:52
0

может кто-нибудь подскажет, что набрать. Nm, eclipse.exe -vm "\ Program Files \ Java \ jdk1.8.0_05 \ jre \ bin \ javaw.exe"

LazerSharks
4 марта 2015 в 17:36
0

Так должен ли путь быть к javaw.exe? Следует ли заменить -version нужной версией? Нравится -x86?

DNA
4 марта 2015 в 20:32
0

Либо java.exe, либо javaw.exe должны работать - мы просто пытаемся выяснить, какая версия Java находится в этой папке. Используйте флаг -version, не заменяйте его ничем - это указывает Java сообщать свою версию, а не запускать что-либо.

user65165
24 июня 2015 в 16:04
0

привет, у меня Program Files <x86> \ Java \ jdk1.8.0_45 \ bin, но я не знаю, что делать отсюда ... Я много пробовал, но ничего не получилось ...

zygimantus
15 июля 2015 в 18:47
0

Использование eclipse.exe -vm "C: \ Program Files \ Java \ jdk1.8.0_25 \ bin" в 64-разрядной версии Windows 7 работает как шарм

Don Cheadle
24 августа 2015 в 14:19
3

так как же заставить Eclipse использовать правильный исполняемый файл / версию Java?

ingomueller.net
25 августа 2015 в 12:04
2

Ответ показывает, как узнать установленную версию Java. Чего не хватает, так это того, какая версия Java требуется!

Ungeheuer
4 сентября 2015 в 00:21
0

@DNA У меня такая же проблема. Я проверил свою панель управления и увидел, что установлены только 64-разрядные версии Java, но в командной строке указано, что я запускаю 32-разрядную версию, и если я перейду в Панель управления> Программы, появится плитка с надписью Java 32-разрядная, но у меня нет 32-битная Java на моем компьютере. что я должен делать?

Ungeheuer
4 сентября 2015 в 00:22
1

@ ingomueller.net требуемый бит зависит от загруженного бита eclipse.

Tomáš Zato - Reinstate Monica
17 сентября 2015 в 14:31
0

Итак, я не могу использовать Eclipse для разработки 32-битных Java-программ или что? Я имею в виду, что в netbeans я без проблем нацелился и на 32-битные, и на 64-битные.

DNA
17 сентября 2015 в 16:53
0

Код Java, созданный Eclipse, будет (как правило) работать на любой платформе, поддерживающей Java: 32-битная или 64-битная Windows, Linux или что-то еще. Этот вопрос касается получения совместимых версий Eclipse и Java, чтобы Eclipse работал.

FractalBob
24 февраля 2016 в 20:47
0

Когда у меня была такая же проблема, я решил ее, отредактировав eclipse.ini и изменив Dosgi.requiredJavaVersion = 1.7 на Dosgi.requiredJavaVersion = 1.8.

Tomer
11 апреля 2016 в 06:34
0

Ваш ответ очень помог! Я думаю, что вы должны указать в своем ответе, как найти второй javaw.exe. Лично я не совсем понял, что мне нужно заглянуть внутрь двоичных файлов других программ и скопировать этот адрес. (а не из программных файлов x86) Наконец, я понял из того, что вы сказали: «Program Files (x86) - это папка, в которой 64-битная Windows помещает 32-битные программы». что, вероятно, jaraws.exe находится в другом Program Files. Опять же, это мне очень помогло!

FatherMathew
2 декабря 2016 в 10:36
0

Я думаю, что это первая из множества проблем, с которыми приходится сталкиваться любому, кто только начинает изучать eclipse ...

Pacerier
18 мая 2017 в 13:27
0

@DNA, что означает "13"?

DNA
18 мая 2017 в 15:21
0

@Pacerier К сожалению, я не смог найти, где задокументировано точное значение.

muman
28 ноября 2019 в 06:48
1

Я переместил путь к 64-битной версии Java в начало списка, а 32-битной версии в конец. Теперь Eclipse стартует как чемпион.