Как увеличить лимит размера импорта в phpMyAdmin

avatar
H. Ferrence
3 октября 2012 в 11:45
349735
19
69

Кто-нибудь знает, можно ли и как увеличить ограничение на размер импорта в phpMyAdmin ? В настоящее время мой сервер ограничен 50 МБ.

Обратите внимание, что это не то же самое, что upload_max_filesize в php.ini. Это значение установлено на 2 МБ.

Мне нужно импортировать таблицу в одну из моих БД, и ограничение phpMyAdmin в 50 МБ на импорт не позволяет мне сделать это.

Спасибо.

Изменено - прилагаются 2 снимка экрана:

Снимок экрана №1 - phpinfo () показывает настройки php.ini. enter image description here Снимок экрана №2 - показывает ограничение импорта phpMyAdmin enter image description here

Источник

Ответы (19)

avatar
mbarthelemy
3 октября 2012 в 11:53
49

Не могли бы вы также увеличить post_max_size и посмотреть, поможет ли это?

При загрузке файла через HTML-форму загрузка обрабатывается как любое другое содержимое элемента формы, поэтому также необходимо увеличить post_max_size.

Обновление: окончательное решение включало командную строку:

Чтобы экспортировать только 1 таблицу, выполните

mysqldump -u user_name -p your_password your_database_name your_table_name > dump_file.sql

и для импорта:

mysql -u your_user -p your_database < dump_file.sql 

'перетащить таблицу your_tabe_name;' также можно добавить в начало сценария импорта, если его еще нет, чтобы таблица была удалена до того, как сценарий создаст и заполнит ее

H. Ferrence
3 октября 2012 в 12:08
0

Спасибо @mbathelemy. Во-первых, это не проблема php.ini с post_max_size. Это значение установлено на 8M. Я добавил к своему вопросу снимки экрана, чтобы точно показать, что я имею в виду. Обратите внимание, что системный администратор хостинговой компании сказал мне, что значение нельзя изменить. Я считаю, что трудно поверить. Разработчики phpMyAdmin жестко запрограммировали это ограничение без возможности изменения?

mbarthelemy
3 октября 2012 в 12:26
0

Если вы думаете, что столкнетесь с проблемами при импорте файла из-за ограничения phpmyadmin в 50MC, вы также БУДЕТЕ достичь пределов php.ini раньше (поскольку они установлены на значения намного ниже 50 МБ)

H. Ferrence
3 октября 2012 в 12:31
0

Спасибо @mbarthelemy, но я не понимаю ваш комментарий. Что интересно, я нахожусь в процессе экспорта и импорта всей БД с 17 таблицами. Все 17 таблиц составляют около 80 МБ. Одна таблица занимает 50,5 МБ (не так ли?). Итак, когда я упаковал остальные 16 таблиц, они составили около 30 МБ, и я смог без проблем их импортировать. Следовательно, 8M post_max_size не используется, и 2M upload_max_filesize тоже не используется. В игру вступает только ограничение phpMyAdmin размером 50 МБ.

mbarthelemy
3 октября 2012 в 12:44
0

@ H.Ferrence большое спасибо за эту дополнительную информацию. К сожалению, и я сожалею об этом, я все еще думаю, что корень вашей проблемы - это значение конфигурации, которое вас ограничивает. Если значения php.ini игнорируются, они, вероятно, где-то переопределяются (внутри конфигурации phpmyadmin?) Кроме того, вы пытались сжать импортируемый файл, чтобы уменьшить его размер, поскольку он, похоже, поддерживается phpmyadmin?

H. Ferrence
3 октября 2012 в 13:07
1

Спасибо @mbarthelemy - импортированные файлы сжимаются и заархивированы с размерами, которые я указал ранее. Я имею в виду, что я разбираюсь во всех аспектах того, что мне нужно делать, как это делать, каковы параметры и ограничения и т. Д. Мне просто нужно знать, как и где разработчики phpMyAdmin устанавливают уровень ограничения 50 МБ и как я может его изменить (если вообще).

H. Ferrence
3 октября 2012 в 13:08
1

(продолжение) Тем не менее - мне трудно поверить, что такой мощный и сложный инструмент, как phpMyAdmin, может позволить разработчикам упустить из виду эту маленькую деталь. Каким-то образом / где-то они подключили значение 50 МБ и поверьте мне, их инструмент проверяет это значение и отклоняет импорт, если размер входящего файла превышает 50 МБ.

mbarthelemy
3 октября 2012 в 13:10
0

Может дело не в оригинальных разработчиках. Я немного погуглил, и phpmyadmin, похоже, не переопределяет настройки php.ini (по крайней мере, те, которые связаны с загрузкой и размером данных). Вы используете Phpmyadmin, предоставленный (и, возможно, «настроенный») хостинг-компанией, или вы настроили его самостоятельно?

H. Ferrence
3 октября 2012 в 13:13
1

установлено хостинговой компанией. плюс я погуглил и обыскал весь форум phpMyAdmin. Там задается множество вопросов точно по той же проблеме, о которой я спрашиваю. И хотите верьте, хотите нет, но каждый вопрос остался без ответа. Изменение лимита phpMyAdmin кажется большой загадкой.

mbarthelemy
3 октября 2012 в 13:20
0

Я знаю, что это определенно прямое решение вашего вопроса, но рассматривали ли вы возможность управления импортом / экспортом из командной строки? Это сэкономит вам время и избавит от головной боли. У вас есть что-то вроде SSH-доступа к вашей базе данных?

H. Ferrence
3 октября 2012 в 13:29
0

У меня есть доступ по SSH @mbarthelemy. Я пытался использовать инструмент phpMyAdmin для оптимизации. Я не совсем понимаю, какие команды использовать в командной строке для импорта экспортированных таблиц БД.

mbarthelemy
3 октября 2012 в 13:34
1

Команды будут очень простыми: для экспорта только 1 таблицы вы должны выполнить 'mysqldump -u user_name -p your_password your_database_name your_table_name> dump_file.sql', а для импорта: mysql -u your_user -p your_database <dump_file.sql

H. Ferrence
3 октября 2012 в 13:37
0

Хорошо, спасибо @mbarthelemy. Будет ли импорт полностью перезаписан существующими таблицами в БД, которая уже настроена на целевом сервере? Я хочу полностью перезаписать его.

mbarthelemy
3 октября 2012 в 13:46
0

Извините, у меня сейчас нет доступа к mysql. вы можете проверить, удаляется ли таблица автоматически при импорте. Если нет, вы можете добавить «drop table your_table» вверху экспортированного файла .sql. Кроме того, поскольку изначально проблема заключалась в том, чтобы заставить phpmyadmin работать, возможно, вы можете проверить файл конфигурации phpmyadmin (который должен называться как 'config.something.inc') на предмет значений конфигурации php, поскольку у вас есть доступ по SSH?

H. Ferrence
6 октября 2012 в 11:42
0

Замечательно @mbarthelemy - импорт из командной строки сработал! Что ж, я знаю, вы знали, что это будет, но это было решением моего ограничения на стороне сервера ...

mbarthelemy
6 октября 2012 в 12:08
0

@ Х. Ферренс рад узнать, что я вам помог! Я обновил свой ответ окончательным решением, даже если оно ненастоящее, учитывая, что первоначальный вопрос был о phpmyadmin

Aswin Kumar
21 ноября 2013 в 07:45
0

Изменение post_max_size устранило проблему для меня на локальном хосте на лампе.

avatar
Saurabh Mistry
30 ноября 2020 в 07:05
1

ЕСЛИ ВЫ ИСПОЛЬЗУЕТЕ NGINX:

  1. cd /etc/php/<PHP_VERSION>/fpm пример => cd /etc/php/7.2/fpm

  2. nano php.ini

    post_max_size = 1024M 
    upload_max_filesize = 1024M 
    max_execution_time = 3600 
    max_input_time = 3600 
    memory_limit = 1024M 
    
  3. после сохранения файла php.ini перезапустите fpm, используя:

    systemctl restart php<PHP_VERSION>-fpm
    

пример => systemctl restart php7.2-fpm

avatar
Muhammad Usman
29 марта 2019 в 16:21
1

Убедитесь, что вы редактируете php.ini, а не php-development.ini или php-production.ini, тип файла php.ini - это параметр конфигурации, и когда вы редактируете его в редакторе, отображается расширение .ini. Вы можете найти php.ini здесь: xampp / php / php

Тогда

upload_max_filesize = 128M
post_max_size = 128M
max_execution_time = 900
max_input_time = 50000000
memory_limit = 256M

enter image description here]

avatar
rushabhpathak
4 сентября 2018 в 06:13
2

перейдите в свою cpanel и выполните поиск «ini editor». Вы получите "Multiphp INI Editor" Здесь вы выбираете свой каталог wordpress и помещаете upload_max_filesize = 256M post_max_size = 256M memory_limit = 256M

enter image description here

avatar
Edwin Martinez
9 октября 2017 в 19:04
0

Ответ Шарки был точным. Отображаемый размер загружаемого файла phpMyAdmin НЕ управляется настройками php.ini, которые вы можете увидеть при запуске phpinfo.php, содержащего:

<?php
// Show all information, defaults to INFO_ALL
phpinfo();
?>

Рекомендуется увеличить настройки php.ini для:

post_max_size upload_max_filesize max_execution_time max_input_time предел_памяти

Вы можете использовать пример настроек, которым поделился Sujiraj R. После того, как вы внесли все изменения как в свой php.ini, так и в область «Tweak Settings» WHM, когда вы запустите phpMyAdmin и перейдете на экран импорта, вы увидите размер, который вы выбрали для «cPanel PHP max upload size» "поле.

На этот пост было много хороших ответов, но нужно было оглядываться, чтобы получить правильный ответ. Я надеюсь, что, включив эти предыдущие ответы в этот пост, я немного помог. Все ответы, на которые я ссылаюсь в этом посте, были получены другими авторами, которые разместили здесь, поэтому, пожалуйста, не приписывайте мне ни одного из ответов, размещенных здесь.

avatar
Mwangi Thiga
16 мая 2017 в 13:32
0

В более новой версии cpanel: поиск ini

Select the Home Directory

Scrool down to 'upload_max_file размер 'и отредактируйте его ... затем сохраните [введите enter image description here

avatar
João Paulo Santarém
13 марта 2017 в 22:22
1

Измените файл phpmyadmin.conf на c: /wamp64/alias/phpmyadmin.conf

php_admin_value upload_max_filesize 512M
php_admin_value post_max_size 512M
php_admin_value max_execution_time 360 ​​
php_admin_value max_input_time 360 ​​

Очень важно увеличить время до 5000 или выше. Таким образом, процесс не остановится, когда вы загружаете большой файл.

Это работает для меня.

avatar
Ankit Shrivastava
24 февраля 2017 в 10:26
8

Сначала вы должны изменить значения в файле php.ini в соответствии с вашими требованиями.

post_max_size = 1024M 
upload_max_filesize = 1024M 
max_execution_time = 3600
max_input_time = 3600 
memory_limit = 1024M 

Примечание. Внимательно измените эти значения. Эти значения будут влиять на все ваши проекты на этом сервере.

Теперь, если вышеуказанные решения не работают, проверьте ваш файл phpmyadmin.conf . Если вы используете WAMP , вы можете найти файл в "C: \ wamp64 \ alias" .

Вы должны изменить указанные ниже значения.

Значения уже в файле -

  php_admin_value upload_max_filesize 128M
  php_admin_value post_max_size 128M
  php_admin_value max_execution_time 360
  php_admin_value max_input_time 360

Измените указанный выше код на -

#  php_admin_value upload_max_filesize 128M
#  php_admin_value post_max_size 128M
#  php_admin_value max_execution_time 360
#  php_admin_value max_input_time 360

Теперь просто перезапустите сервер, чтобы работать с измененными значениями. :)

avatar
bestshop24h
30 декабря 2016 в 12:00
1

1: nano /etc/php5/apache2/php.ini
вы можете найти свое местоположение php.ini, загрузив файл с именем phpinfo.php со следующим содержимым <?php phpinfo();?> и получить к нему доступ, посетив yourdomain.com/phpinfo.php, вы увидите результаты

2: измените желаемое значение на upload_max_filesize и post_max_size Такие как : upload_max_filesize = 200 МБ post_max_size = 300 млн тогда он станет 200M.

3: перезапустите apache

avatar
Sujiraj R
19 октября 2016 в 06:35
0

Вы можете искать файл php.ini в C: \ xampp \ htdocs

изменяется в php.ini файл

post_max_size = 805M 
upload_max_filesize = 805M 
max_execution_time = 5005 
max_input_time = 5005 
memory_limit = 1005M 

После редактирования Пожалуйста, перезапустите XAMPP

avatar
12 октября 2016 в 06:48
5

Вы можете увеличить лимит из файла php.ini. Если вы используете Windows, вы получите файл php.ini из каталога C: \ xampp \ php.

Теперь изменяет следующие строки и устанавливает предел

post_max_size = 128M
upload_max_filesize = 128M 
max_execution_time = 2000
max_input_time = 3000
memory_limit = 256M
avatar
Abey
7 июля 2015 в 10:53
36

Измените эти значения в php.ini

post_max_size = 750M 
upload_max_filesize = 750M 
max_execution_time = 5000 
max_input_time = 5000 
memory_limit = 1000M 

Затем перезапустите Wamp, чтобы изменения вступили в силу. Это займет некоторое время. Если вы получите следующую ошибку:

Истекло время ожидания сценария, если вы хотите завершить импорт, пожалуйста, повторно отправьте тот же zip-файл, и импорт будет возобновлен.

Затем обновите конфигурацию phpMyAdmin в phpMyAdmin \ libraries \ config.default.php

/**
 * maximum execution time in seconds (0 for no limit)
 *
 * @global integer $cfg['ExecTimeLimit']
 */
$cfg['ExecTimeLimit'] = 0;
avatar
Heath
18 мая 2015 в 08:39
0

Я увеличил максимальный размер файла, перейдя в CPanel> Выберите версию PHP> Переключитесь на расширения PHP, а затем прокрутите до поля upload_max_filesize (у него будет кликабельная ссылка для размера - мой был установлен на 2 МБ), и я увеличил его до 256 МБ. Затем нажмите «Сохранить».

avatar
ramird23
24 апреля 2015 в 02:26
5

это связано с ограничением импорта размера файла в phpmyadmin, значение по умолчанию очень низкое, поэтому вам следует увеличить upload_max_filesize вы можете изменить это в своем php.ini, заменив этим

upload_max_filesize = 100M

avatar
Edy Aguirre
8 мая 2014 в 17:01
60

У меня была та же проблема с моей правильной работой, выполнив следующие действия

изменяется в файл php.ini

post_max_size = 800M 
upload_max_filesize = 800M 
max_execution_time = 5000 
max_input_time = 5000 
memory_limit = 1000M 

теперь перезапустите, чтобы изменения вступили в силу

Tyler Collier
2 ноября 2015 в 17:27
2

В моей локальной среде phpmyadmin мне нужно было только изменить post_max_size и перезапустить apache. Затем новый размер был показан в разделе phpmyadmin «Файл для импорта». Но я полагаю, что если ваш сервер удален и / или ваш загружаемый файл большой, вы захотите изменить эти другие значения.

avatar
Irfan Ullah Khan
29 ноября 2013 в 06:56
8

У меня была такая же проблема. Мой файл .sql был 830 МБ, а разрешенный размер импорта phpMyAdmin был 50 МБ (как показано на скриншоте). Когда я заархивировал файл в .zip, его размер стал примерно 80 МБ. Затем я заархивировал его в формат bzip2 и был поражен, увидев, что размер файла был сжат всего до 12 МБ (с 830 МБ до 12 МБ !!!). Поскольку phpMyAdmin допускает три типа сжатия, то есть .zip, .gzip и .bzip2, поэтому я загрузил сжатый файл bzip2 и альт .... он был импортирован в базу данных !!! Итак, используя правильное сжатие, я смог импортировать файл .sql размером 830 МБ в phpMyAdmin.

ПРИМЕЧАНИЕ: страница импорта phpMyAdmin четко указывает, что сжатое имя файла должно иметь вид filename.sql.bz2 . Это не должно быть похоже на filename.bz2.

ПРИМЕЧАНИЕ 2: Вы можете сжать файл .sql в сжатый файл bzip2 с помощью программного обеспечения 7-Zip. cPanel также имеет возможность сжать файл в формат bzip2.

avatar
Randika
19 ноября 2013 в 22:18
2

если вы используете xampp, найдите php.ini (в самой папке xampp), перейдите к строке 735 и измените post_max_size на желаемое значение. пример: если вы хотите перейти на 80 МБ,

post_max_size = 80M

не забудьте перезапустить apache после изменения значения.

Вот и все ...

Martyn Shutt
17 мая 2015 в 15:09
2

Да, именно это значение влияет на максимальный лимит загрузки в phpmyadmin. Другие упомянули об этом, но также упомянули об изменении других настроек, которые косвенно связаны. Иногда лучше просто изменить только ту настройку, которая вам нужна, чтобы вы знали, какая настройка что делает. Если вы достигнете других пределов, вы измените их по мере продвижения.

avatar
Sharky
17 октября 2013 в 08:09
65

Если вы используете WHM / Cpanel, то для изменения ограничения «Макс: 50 МБ» в разделе импорта phpmyadmin вам нужно будет изменить два значения в WHM (Web Host Manager).

Шаг 1) Перейдите в настройки Tweak, найдите параметр «Максимальный размер загрузки cPanel PHP», измените его в соответствии с вашими потребностями. Сохраните изменения.

Шаг 2) Перейдите в настройки Tweak, найдите «cPanel PHP Max POST size», измените его в соответствии с вашими потребностями. Сохраните изменения.

Вернитесь в свой phpMyadmin. Значение должно было измениться.

enter image description here

enter image description here

enter image description here

gin93r
26 августа 2014 в 21:24
2

Это мне очень помогло. Я устанавливал ограничения в конфигурации php, и они не принимали. Это исправило это. Спасибо!

progammingaddict
27 октября 2014 в 02:36
2

Почему это не лучший ответ? Потому что это решение! БЛАГОДАРЮ ВАС! (Сработало!) P.s. вы можете увеличить до 2047 МБ, чего было достаточно для моих нужд. p.s.s. перезагрузка не требуется, просто сохраните и ГОТОВО!

Harsha
14 июля 2015 в 18:59
3

Действительно полезно, это должен быть принятый ответ.

NinjaKC
27 ноября 2016 в 01:57
0

Сначала это не сработало для меня, мне пришлось перезагрузить весь сервер, чтобы он обновился для phpmyadmin, хотя после этого он работал. Спасибо

Ramesh S
21 июня 2017 в 13:47
0

Спасибо за ответ. Я использую VPS, он не изменился. Или требуется время, чтобы изменить значение ..?

Deepti chipdey
26 марта 2018 в 16:26
0

Большое спасибо, ты спас мне день

George Chalhoub
31 июля 2019 в 14:29
0

Отличный ответ! Спасибо.

Les Brown
22 апреля 2020 в 14:57
0

Спасибо! Изменения в php.ini через WHM не устранили проблему в моей установке. Использование этого метода и обновление значений в настройках твика устранили проблему без перезагрузки.

KingRichard
28 мая 2021 в 23:02
0

Это была моя проблема. Я не думаю, что мне когда-либо приходилось возиться с этой настройкой за мою 14-летнюю карьеру, но у меня также обычно нет ненужных больших баз данных для миграции. Спасибо!

avatar
tibasce
6 июня 2013 в 17:16
2

Если у вас есть прямой SSH-доступ root к машине, вы сможете изменить настройки в: /usr/local/cpanel/3rdparty/etc/phpmyadmin/php.ini

Просто измените строку: upload_max_filesize = 50M

Esoteric Screen Name
6 июня 2013 в 17:41
3

Вы не читали вопрос? Please note that this is not the same as the upload_max_filesize in php.ini. That value is set to 2MB.