Не удалось найти индексную страницу для «flickrapi» (возможно, с ошибкой?)

avatar
Rex Block
7 апреля 2018 в 22:24
2232
0
0

Я работаю над установкой пакета flickr-views-counter. Я хочу использовать это в качестве базы кода для разработки более надежного набора подпрограмм flickr для приложения CLI.

Я могу правильно установить его, используя

pip install flickr-views-counter

Но когда я клонирую его из git, а затем использую программу установки, я получаю

Searching for flickrapi
Reading https://pypi.python.org/simple/flickrapi/
Couldn't find index page for 'flickrapi' (maybe misspelled?)
Scanning index of all packages (this may take a while)

А именно -

python setup.py build 
running build 
running build_py

за которым следует -

sudo python setup.py install
Password:
running install
Checking .pth file support in /Library/Python/2.7/site-packages/
/usr/bin/python -E -c pass
TEST PASSED: /Library/Python/2.7/site-packages/ appears to support .pth files
running bdist_egg
running egg_info
...
Installing flickr-views-counter script to /usr/local/bin

Installed /Library/Python/2.7/site-packages/flickr_views_counter-0.1.0-py2.7.egg
Processing dependencies for flickr-views-counter==0.1.0
Searching for flickrapi
**Reading https://pypi.python.org/simple/flickrapi/
Couldn't find index page for 'flickrapi' (maybe misspelled?)
Scanning index of all packages (this may take a while)
Reading https://pypi.python.org/simple/
No local packages or download links found for flickrapi
error: Could not find suitable distribution for Requirement.parse('flickrapi')**

requirements.txt содержит только строку "flickrapi".

Страница https://pypi.python.org/simple/flickrapi/ содержит десятки заархивированных файлов tar flickrapi и egg-файлов.

Нужно ли мне использовать определенную версию flickrapi, чтобы это работало? Какую индексную страницу он ищет?

Спасибо за любую помощь. flickrapi устанавливается нормально с установкой pip, но не через установку. Все еще не понимаю, как это работает.

Источник
hoefling
8 апреля 2018 в 19:33
0

1. Вы за прокси? Проверьте, например, curl https://pypi.python.org/simple/flickrapi работает. 2. Есть ли у вас файл ~/.pydistutils.cfg? Если да, напишите что там.

Rex Block
8 апреля 2018 в 22:03
0

(1) нет ответа, просто быстрый возврат и выход, код выхода = 0 (2) у меня нет этого файла.

hoefling
8 апреля 2018 в 22:30
0

А, это из-за перенаправления - можешь попробовать curl -L https://pypi.python.org/simple/flickrapi? Вы должны получить HTML со списком различных версий пакета.

Rex Block
8 апреля 2018 в 22:37
0

Там много! Всего 54 строки, все разные версии flickrapi от 0.15 до 2.4.0, а также смесь zip, egg и whls.

Ответы (0)