Flutter Doctor не запускается в командной строке

avatar
nick.tdr
8 апреля 2018 в 11:35
1786
1
0

Я использовал флаттер плавно до этого, но вдруг, когда я запускаю флаттер-доктор в командной строке, я получаю следующую ошибку.

Обновление инструмента флаттера... Не удалось найти файл с именем "pubspec.yaml" в "C:\Users\personal\AppData\Roaming\Pub\Cache\hosted\pub.dartlang.org\linter-0.1.43". Ошибка: невозможно установить флаттер-инструмент «pub upgrade». Повторная попытка через пять секунд...

Я также удалил плагин flutter и dart из студии Android, но это не помогло.

Источник
Blasanka
8 апреля 2018 в 12:37
0

Вы повторили попытку через пять секунд?

nick.tdr
8 апреля 2018 в 12:48
0

Да, что я пытался сделать в первую очередь

Günter Zöchbauer
8 апреля 2018 в 13:17
0

Вероятно проблема в сети. Вы находитесь в Китае или за другим брандмауэром.

nick.tdr
8 апреля 2018 в 13:21
0

Нет, я не из китая. Моя сеть тоже работает нормально

Blasanka
11 апреля 2018 в 03:35
0

Если его все еще не удается решить. Вы можете сообщить об ошибке здесь: github.com/flutter/flutter/issues/new

nick.tdr
11 апреля 2018 в 03:41
0

Спасибо за ответ. Я сохраню это на будущее, но я решил свою проблему, и я дал решение ниже.

Ответы (1)

avatar
nick.tdr
8 апреля 2018 в 14:42
1

Я удалил папку кеша в следующем месте.

C:\Users\personal\AppData\Roaming\Pub\Cache\

Теперь мой флаттер-доктор снова работает.