как исправить эту ошибку при установке пакетов радия в терминал vs code?? спасибо

avatar
BMKHAN
26 октября 2020 в 07:28
2705
3
5

PS C:\Users\BM KHAN\react-guide> npm install --save радий нпм ОШИБКА! код ERESOLVE нпм ОШИБКА! ERESOLVE не удалось разрешить дерево зависимостей нпм ОШИБКА! нпм ОШИБКА! При разрешении: react-guide@0.1.0 нпм ОШИБКА! Найдено: реагировать@17.0.1 нпм ОШИБКА! node_modules/реагируют нпм ОШИБКА! react@"^17.0.0" из корневого проекта нпм ОШИБКА! нпм ОШИБКА! Не удалось разрешить зависимость: нпм ОШИБКА! одноранговая реакция@"^16.8.0" от радия@0.26.1 нпм ОШИБКА! node_modules/радий нпм ОШИБКА! радий@"*" из корневого проекта нпм ОШИБКА! нпм ОШИБКА! Исправьте конфликт зависимостей восходящего потока или повторите попытку. нпм ОШИБКА! эта команда с --force или --legacy-peer-deps нпм ОШИБКА! принять неправильное (и потенциально нарушенное) разрешение зависимостей. нпм ОШИБКА! нпм ОШИБКА! Полный отчет см. в C:\Users\BM KHAN\AppData\Local\npm-cache\eresolve-report.txt.

npm ОШИБКА! Полный журнал этого запуска можно найти в: нпм ОШИБКА! C:\Users\BM KHAN\AppData\Local\npm-cache_logs\2020-10-26T07_23_09_921Z-debug.log PS C:\Users\BM KHAN\react-guide>

Источник
BMKHAN
26 октября 2020 в 07:33
0

@Raja jaganthan помоги мне

Raja Jaganathan
26 октября 2020 в 07:35
0

Добро пожаловать ТАК! попробуйте очистить кеш с помощью этой команды «npm cache clean --force», затем выполните npm install

BMKHAN
26 октября 2020 в 07:39
0

сэр все еще сталкиваюсь с той же ошибкой

imran shoukat
26 октября 2020 в 07:56
0

Пожалуйста, внимательно прочитайте ошибку. Он говорит вам, что вы можете сделать, чтобы исправить ошибку.

Ответы (3)

avatar
Mohammad Refaldo Rachman
16 марта 2021 в 07:32
0
npm install --save radium --force
avatar
Sayed Mehtab
27 ноября 2020 в 14:08
2

Это сработало для меня, у меня тоже такая же проблема. Если мы прочитаем ошибки в настоящее время, мы сможем легко их исправить

enter image description here

npm install --save radium --legacy-peer-deps
corn on the cob
27 ноября 2020 в 19:43
0

вы можете опубликовать ошибки в виде текста, пожалуйста? Спасибо!

avatar
sandesh sinha
30 октября 2020 в 18:31
11

Мне помогло, у меня была та же проблема

npm install --save radium --legacy-peer-deps