«Не удалось разрешить зависимость», ошибка при запуске «обновления vue»

avatar
zachThePerson
8 августа 2021 в 22:34
1714
1
4

Я пытаюсь использовать инструкции здесь для установки миграционной сборки Vue 3.

Когда я дохожу до точки, где вам предлагается запустить vue upgrade, я выбираю y для установки обновлений, после чего появляется следующая ошибка

npm ERR! code ERESOLVE
npm ERR! ERESOLVE unable to resolve dependency tree
npm ERR!
npm ERR! While resolving: ed_editor@0.1.0
npm ERR! Found: vue@2.6.14
npm ERR! node_modules/vue
npm ERR!   vue@"^2.6.11" from the root project
npm ERR!
npm ERR! Could not resolve dependency:
npm ERR! peer vue@"3.1.5" from @vue/compiler-sfc@3.1.5
npm ERR! node_modules/@vue/compiler-sfc
npm ERR!   peer @vue/compiler-sfc@"^3.0.0-beta.14" from @vue/cli-service@4.5.13
npm ERR!   node_modules/@vue/cli-service
npm ERR!     dev @vue/cli-service@"~4.5.13" from the root project
npm ERR!
npm ERR! Fix the upstream dependency conflict, or retry
npm ERR! this command with --force, or --legacy-peer-deps
npm ERR! to accept an incorrect (and potentially broken) dependency resolution.
npm ERR!
npm ERR! See C:\Users\Zach\AppData\Local\npm-cache\eresolve-report.txt for a full report.

npm ERR! A complete log of this run can be found in:
npm ERR!     C:\Users\Zach\AppData\Local\npm-cache\_logs\2021-08-08T22_29_19_955Z-debug.log
 ERROR  command failed: npm install --loglevel error @vue/cli-service@~4.5.13

Я прочитал сообщение об ошибке, но не знаю, как решить проблему. Я попытался использовать --force, но позже это вызвало больше проблем.

Как мне это решить?

Источник

Ответы (1)

avatar
Trott
9 августа 2021 в 01:54
3

Вероятно, вы используете npm версии 7. (Используя npm версии 7, я смог воспроизвести вашу ошибку на основе вашего сообщения об ошибке.) Самые простые решения:

  • Использовать флаг --legacy-peer-deps --legacy-peer-deps npm
  • Использовать npm версии 6 (где поведение флага --legacy-peer-deps версии 7 npm 7 используется по умолчанию)

Учебник и пакеты, вероятно, были написаны и протестированы с npm версии 6 (или, возможно, 5 или 4). Многие существующие проекты сталкиваются с этой ошибкой ERESOLVE в npm версии 7, потому что в этой версии проблемы с одноранговыми зависимостями стали рассматриваться как ошибки, а не рекомендации, которые можно было игнорировать.