Rust: ошибка сборки шаблона узла субстрата

avatar
Ilyssa
8 августа 2021 в 23:40
513
1
1

Я следовал этим инструкциям:

Я получаю следующую ошибку после попытки запустить этот код:

cd substrate-node-template
# NOTE: you should always use the `--release` flag
cargo build --release
# ^^ this will take a while!

Это ошибка, есть идеи, что происходит?:

  Downloaded approx v0.3.2
  Downloaded parity-db v0.2.3
error: failed to parse manifest at /Users/ilyssaevans/.cargo/registry/src/github.com-1ecc6299db9ec823/parity-db-0.2.3/Cargo.toml


Caused by:
  failed to parse the version requirement `0.11 ` for dependency `parking_lot`

Caused by:
  expected comma after minor version number, found '\t'
zsh: command not found: # 
Источник
Jonathan Leffler
9 августа 2021 в 00:05
0

На первый взгляд, есть проблема с копией parity-db v0.2.3, которую вы загрузили, или, возможно, с этой версией в репозитории GitHub.

ox12
9 августа 2021 в 00:59
0

Пожалуйста, обновите paritydb Если это не работает, удалите кеш груза и переустановите все

Ответы (1)

avatar
Clark Lee
9 августа 2021 в 03:27
1

выполнить

обновление груза -p parity-db

Если это не поможет, очистите кеш грузов и переустановите