Периодическое получение 502 для прокси-сервиса от NgInx на Openshift

avatar
SoumitraM
9 августа 2021 в 05:35
203
0
1

Я периодически получаю 502 для службы прокси. Я пытаюсь настроить прокси NgInx в Openshift. Периодически выдает ошибку 502 Bad Gateway. Вот мой файл nginx.conf.


#user  nobody;
worker_processes  1;
error_log stderr;
events {
    worker_connections  1024;
}


http {
    include       mime.types;
    default_type  application/octet-stream;
    server_tokens off;
    sendfile        on;
    tcp_nopush     on;

    gzip on;
    gzip_comp_level 3;

    keepalive_timeout  65;

    underscores_in_headers on;

    server {
        charset utf-8;
        root   /usr/share/nginx/html;
        listen       8443 ssl http2;
        server_name  proxy-svc;
        add_header X-Frame-Options "SAMEORIGIN";
        add_header X-XSS-Protection "1; mode=block";
         # SSL config
        ssl_certificate /etc/tls/private/tls.crt;
        ssl_certificate_key /etc/tls/private/tls.key;
        # Disable SSL and enable TLS
        ssl_protocols TLSv1.2 TLSv1.3;
        # Cipher suits
        ssl_prefer_server_ciphers on;
        ssl_ciphers EECDH+AESGCM:EDH+AESGCM:AES256+EECDH:AES256+EDH;

        # SSL session caching
        ssl_session_cache shared:SSL:40m;
        ssl_session_timeout 4h;
        ssl_session_tickets on;
        
        # Enable HSTS
        add_header Strict-Transport-Security "max-age=31536000" always;

        resolver  dns-default.openshift-dns.svc.cluster.local valid=10s;
        
        proxy_set_header        Host                $host;
        proxy_set_header        X-Real-IP           $remote_addr;
        proxy_set_header        X-Forwarded-Proto   $scheme;
        proxy_set_header        X-Forwarded-For     $proxy_add_x_forwarded_for;
        proxy_pass_request_headers on;
        #  Service name: apimanager_svc
        location /apimanager {
            set $upstreamapi https://apimanager_svc.<namespace>.svc.cluster.local:10666/api/v1/;
            proxy_pass  $upstreamapi$request_uri;
        }
        # Service name: ui-svc
        location / {
            set $upstreamui http://ui-svc.<namespace>.svc.cluster.local/;
            proxy_pass  $upstreamui$request_uri;
        }
    }
}

Я добавил файл целиком, потому что не уверен, что что-то пропустил/неправильно настроил. Запрос выполняется нормально почти в 50% случаев. Несколько замечаний:

  1. Прокси работает через https
  2. Ошибка 502 наблюдается только для apimanager_svc (также https)
  3. Оба прокси-сервиса используют golang beego v2 https://beego.me/

версия nginx: nginx/1.18.0 версия openshift: 4.7

Источник

Ответы (0)